3DS Max exporter sets normal strength first material for all materials?

Hi @Guillaume_Pelletier ,

I hope I’m correct in pinging you in this question, as you seem to be the 3DS Max exporter guru :blush:

I have a scene (see attached 3DSMax 2019 scene with texture) to export into a gltf/glb file.

The first material has a normal intensity of 0, th second of 2.

When I export this manually or with Maxscript, the first normal intensity is used for both materials.

The gltf json file states:


for both materials.

When I switch the normal intensity of the materials, the gltf json file states:


for both materials.

Am I doing something wrong? :sweat_smile:

Thank you for any feedback!

2_normal_materials_Max2019.zip (43.8 KB)

Hi @FernandoConti , hope you’re well. I’m in break actually. This seem an issue, i will have a look on it. Thank’s for flag this.

Guy’s, this has to deal with Babylon to gltf at this line , when the transform process try to optimize texture. Introducing scale value into the optimization id make the trick. I have to dig a bit more to understand also if the process is doing correctly when using KHR extension

keep u posted

Great, thank you Guillaume! Sorry to disturb you during your break :innocent: