Android UC Browser => Page Reloads leads to "invalid uniform block index" warning & invisible scene

i’ve encountered a problem with the Chinese UC-Browser.

Device used: Samsung Galaxy S8
Browser: UC-Browser - version (release & developer build)

When opening a scene for the first time everything looks fin, however sometimes, (or latest when the page got reloaded) many/all objects in the scene aren’t visible anymore.
Also in the developer console an error is thrown:

Blockquote WebGL: INVALID_VALUE: uniformBlockBinding: invalid uniform block index

This is also reproducable on Playgrounds.
One example on playground i’ve found and used to reproduce was: (it isn’t from me)

Left side is how the scene should looks like:
(note: the left image is from desktop since I wasn’t able to get the full scene working again on that device)
And right side is how it looks like after reloading the page

As you can see, the background, the ground and the walking men are gone.
Also with the error message i’ve mentioned above (appeared several times)

The playground Babylon.js version is v4.1.0-beta.20
This also happens in our project with Babylon.js v4.0.3.

Did anyone already had such an issue with the UC-Browser?
It works well on other browsers (chrome, firefox, stockbrowser)

thanks in advance

Unfortunately I cannot repro :frowning:
Can you try to turn off webgl2 maybe when creating the engine?

I did not reproduce the problem either, but when clicking several times quickly on the button to restart the PG, I got:

Probably because of the parallel nature of shader compilation

Thanks for the replies.
That’s weird, I can reproduce this issue on multiple different devices.

Until now tested on:
Samsung Galaxy S8
Samsung Galaxy S9+
Xiaomi Redmi Note 7.

Downloaded on all the UC Browser ( ) Version
This issue doesn’t occur on other browsers like Chrome & Firefox.

image WebGL2 is enabled, so I will try it to turn off WebGL2, if I can find out how to do, and how to save an Playground. I’ll post the results when i am done.

Seems that disabling WebGL2 Support fix this Problem.
Thanks for this advise and Help.

Does anyone know why this happens if WebGL2 is enabled?

(Note: I was not able to disable WebGL2 support in the Playground. I got always a “WebGL is not supported” error if I tried it there)

Yeah disabling webgl2 must be done when creating the engine.

You can safely disable it as we guarantee back ward compatibility :slight_smile: