Black canvas on ipad pro using latest version

When I try to load a scene with SSS (PrePassRenderer) enabled on the latest version (Beta.4), the canvas turns completely black.
A demo playground:
If I change the version to 4.2.1 it renders but the SSS is somewhat messed up.

iPad Pro
Version: 15.2.1 (latest)

@sebavan - is that a known issue with iOS?

My iPad Pro 15.1 shows correctly in Chrome and Safari with the latest 5.0.
For 4.2.1 there is black-and-white mesh.

After upgrading to 15.2.1 I have the same results.

So it seems to be an isolated case on @Forsakenā€™s device?

@Forsaken, just to be sure, would you be able to try clearing cache completely and see if the results are different?

I have just tried, and the result is the same. @RaananW




thumbnail_test lag prepass  Babylon.js Playground

Nothing I can think of and I unfortunately can not repro either :frowning: @Deltakosh can you try on your ipad pro ?

I do not repro either

any chance your turned webgl2 off?

1 Like

Definitely on sadly enough, I did try changing some of the settings on safari but none of it really fixed it.

Here is iPhone8 Chrome screenshot (Safari has the same results)

We need more testers to be objective :slight_smile:

I know this issue. It also happens on my IPhone SE 2020. It is because of the buggy WebGL 2 support in IOS.

1 Like

Same here. iPad Pro M1.
Have noticed this on different projects already.
First thought it was because the texture size exceeded a limit?

Oh might be a M1 only issue ???

1 Like

The iPad pro Iā€™m using is not a M1 version however.

@Forsaken what is the version of your IPAD os and Safari version ?

15.2.1 for both.

@Deltakosh are you also on 15.2.1 on your IPad pro ? so weird ā€¦

15.2.1, Chrome

I was not. I updated yesterday