Blender2Babylon Plugin defect

#1

I am using Exporters/Blender2Babylon-6.0.zip at master · BabylonJS/Exporters · GitHub on Windows 10

This is the error report when I click on the checkbox to enable the plugin:

PS: No error occured with the version 5.6.4

#2

Pinging @JCPalmer who is the mastermind behind our blender exporter

#3

Sorry, but you are trying to load Export version 6.0 on Blender 2.79. This is not going to work. Errors like this are caused by Blender 2.80 having very many breaking changes. The exporter for 2.80 is never going to run on anything earlier.

On the plus side, the exporter 6.0 supports both PBR & standard materials via Nodes. It is a big UI change though. When You cannot find something, right click for a context sensitive menu.

Also, do not load your old .blend files directly. Create new ones, and use File->Append. Throw away old lights & recreate them in Blender 2.80.

Although Blender 2.80 is not yet production, it probably could be from my usage. I have not un-installed 2.79, but I never run it anymore.

#4

Thank you. Your hint would be helpful for everyone else on this page:

https://doc.babylonjs.com/resources/blender#installation