Build error in version 5.0.0-beta.9

After update to 5.0.0-beta.9, if I run “ng serve --open”, I will get error:


How to fix it?

This seems to be a problem with your typescript version. What version do you use?

lastversion: Version 4.5.5

Is the same version installed locally in your project as a devDependency?

I run “tsc -v” in project ,is Version 4.5.5

What do you have in your package.json?

image

1 Like

Last time i checked, Angular cli still enforces a specific version or less of typescript because google does google wide upgrades of compiler dependencies in their build system, which of course they have to test so it lags a little behind typescript releases.

HouLing, You can declare a global type inside a ambient.d.ts for the missing type as any or copy paste it from the latest typescript dom.d.ts. You could also just turn off type checking, its only a type error.

2 Likes

Thank you very much! Angular cli still limit typescript version <4.2.0

1 Like

Thank you very much!