Help with close zoom in Playground


I got a problem. I am using Babylon .glb converter in Maya and once I check my skeleton model in a Babylon Playground area, it does not let me zoom in for ex. to a knee area (essentially close up). Once the textures are removed, everything works well.

I noticed that happens with any other models, that has got a texture on.

Could anyone explain what is happening? Also is there a solution for this?

Thank you in advance!!!

Welcome aboard!

I’m not sure to understand, could you setup a simple repro in the Playground so that we can have a look?

This doc may help you hosting assets that you want to use in the Playground: Using External Assets In the Playground | Babylon.js Documentation

1 Like


Thank you for the answer!

In a pic no1. I am using textures for the model and that is as far as I can zoom in. In a pic no.2, I have taken all of the textures and left plain material on, but that allows me to zoom in as much as I want.

By any chance, would you know why that would be happening?

Hope that is a bit more clear!
Thank you!

(P.S. It is all .glb export from Autodesk Maya, using Babylonjs plug-in, Apologies, I meant the Sandbox rather than a Playground! I am very new to this )

I can’t see why having textures would make zooming different than if you don’t have textures…

I think you will need to provide the 2 .glb files so that we can test ourselves.

1 Like


My bet is that the Maya exporter is setting a default camera with high limits, which do not allow you zoom the camera closer to where you want. This happened to me in a project I worked, to solved, in Sandbox, just open the LIMITS left menu with the camera selected, and change the “lower radius limit” value to 0 or 1. (like in attached pícture)