How to get rid of MeshButton3D default zoom behavior

I am trying to get rid of the default “hover scale-up” behavior of the MeshButton3D.

I have tried setting the onPointerEnterAnimation to null but it is not working for me.

Looking for some guidance, thanks!

Hiya H. Here’s a playground I found… by in-code playground search for 'MeshButton3D’:

Things appear to be working, in there. I disabled the playground-author’s custom pointerEnterAnimation in lines 35-38 (which lets the BJS default animation start working again).

But then I added line 40 animation hand-grenade… wiping-out the BJS default… and leaving a non-animated pointer-enter. Yay! :slight_smile:

Notice it is pointerEnterAnimation. No ‘on’ and no capital ‘P’. :slight_smile: Me suspect-eth: THIS was the cause of your troubles. :slight_smile: It’s a common stumble. We ALL do it… sometimes. I hope this helps. Keep us posted and/or mark solved if we ever get there. :slight_smile: Party ‘on’ !

1 Like

Thanks Wingnut!
I confused the property name with onPointerEnterObservable.

1 Like