Jiggling shadow-edges

Has someone a tip to get better shadow than the one in my sampling image.

The actual setting are:
shadowGenerator = BABYLON.ShadowGenerator(1024, this.MainLight, true);
shadowGenerator.usePoissonSampling = true;
shadowGenerator.forceBackFacesOnly = true;
shadowGenerator.usePercentageCloserFiltering = true;
shadowGenerator.transparencyShadow = false;
shadowGenerator.bias = 0.001;

I don’t want a very high mapSize so is there onther option the make the shadows “smooth”

Thx :wink:

@Pe443 , maybe you can try adding Kernel blur to make the shadows event smoother?

I can try adding the following properties to your ShadowGenerator:

shadowGenerator.useKernelBlur = true;
shadowGenerator.blurKernel = 64;

@ srzerbetto Thx
I have found the reason for the shadows.

My light position was toooo fare away
OLD: new BABYLON.Vector3(0, 2000, -200);
NEW: new BABYLON.Vector3(0, 100, -10);

Now it looks like this:

Maybe it helps someone else who has the same problem :wink:

1 Like