PhotoDome invisible after GLB Import

Hi!
I’ve run into a strange problem with the PhotoDome which I can’t resolve. I can create a PhotoDome with a 360° texture and everything works just as intended.
The problem is, that the exact same PhotoDome (generated using the same code) doesn’t show up at all when I’m importing a GLB scene (created in Blender). I just get the standard blue Background instead of the PhotoDome. It doesn’t make any difference whether I create the PhotoDome before or after importing the GLB scene. Also, seen when inspecting the scene object, the PhotoDome mesh and material are part of the scene and appear to be perfectly fine. For some reason it’s just not being rendered.
I’ve checked a bunch of stuff already and I’m running out of ideas what could be the reason for this.
Thank you for your help!

Ok I found the issue and solved it. I was using cameras from the GLB scene which had their “maxZ” value set to 100. Turns out the PhotoDome is further away then that so setting the “maxZ” value to 10000 (the default value for cameras created in Babylon) solves the issue. Maybe this is helpful for someone else with the same problem so I’ll keep it online for now.

2 Likes

Welcome to the community @ludwig!