Poor (Device) Camera quality in AR

I just purchased a Samsung S6 Lite Tablet to expand my device testing pool for AR beyond my existing S8 Phone. The new tablet’s camera can take a good quality photo, but as soon as I fire up Google’s AR Depth Lab, or my development environment for BabylonJS, the image quality gets blurry, the video feed lags, and generally performance is very poor in AR.

This does not happen on my existing phone which is almost five years old, the video on that device is sharp, and has very little lag / ghosting to the point where its not noticeable. The new tablet is the only device with this issue. But since its not happening in one app only, I am wondering if this may be a device issue, ARCore setting, or something else.

Pics attached. The first is just the camera taking a photo of the floor, second is in Depth Lab, third is in one of my BabylonJS WebXR AR apps. You can’t see the lag, but you can see the quality difference clearly in things like wood grain.

I know this is not really a BabylonJS specific question, but maybe someone has seen this before. Does anyone have an idea what would cause this? Is this just a device issue that is not fixable or are there tweakable settings that can improve the overall performance quality of ARCore?

I know @RaananW is doing AR test ATM. Maybe there is some ways to tweak the camera quality?

I can’t say a lot of good things about apple (because of how much i love this company), but there are a few things they are doing better than the rest. one of them is not allow features that are not fully supported on older devices. a galaxy s6 is an 8 years old device (released 01.03.2015). This device’s GPU is a very old Mali (ARM Mali-T760 MP8 - NotebookCheck.net Tech). Google should not have allowed running AR experiences on this device - it’s almost guaranteed that the quality will be … not the best?

I also assume you are running a much older OS than the S8. I believe the S6 was upgraded to max android 8 or 9, which is also not the most optimized version of this OS.

I don’t know of any tweaks to be done to AR core, apart from trying a different ROM on your device, upgrading it to a newer version of the OS and seeing if that improves the experience. From searching quickly I see that there are ports of android 12 (unstable) and 11 (stable) for the S6. will need a new bootloader, but it’s a rather straight-forward procedure. Of course, don’t take that advice if you don’t know what you are doing and also know that it might break the device…


Yes, it may just go back in the box. A bit annoyed as it was a latest revision 2022 of the device and I thought it was running Android 12. Its annoying as it was the most “common” tablet I was able to find in the usual big-box USA stores (Walmart, Target, Best Buy, Sams Club, BJ’s, and computer stores Microcenter, B&H), with slightly higher specs than the Samsung A8 Tablet (equally represented in # of stores), so seemed like a perfect target device to represent what the “average” user may be using :frowning:

Sadly, my five year old S8 phone runs circles around it in AR.

I was hoping for a setting in ARCore or Chrome but did not see anything when searching last night.

wait, i just notices you meant an s6 tab. i thought you meant the mobile device.

in ay way, ARCore is poorly configurable…

Yes, its the S6 Lite Tablet https://www.samsung.com/us/mobile/tablets/tab-s6-lite/

It should be more than up to the job, and the cam itself can produce great image quality if not in AR mode… Its something in ARCore, or some sort of limit with the tablet when using ARcore. But, it does not make a lot of sense so was hoping it was a configurable thing. Its not babylonJS specific, Google’s depth lab demo has the same exact issue as BabylonJS.

1 Like