Problems loading models after updating to version 5.45.0

I’m trying to load a 3D model and it’s throwing some weird erros, maybe someone can give me an idea of what I’m doing wrong.

This happened as I updated to version 5.45.0 of babylon js using yarn.

And as I tried to downgrade back down to a previous version I also encounter this error when loading a model, which I’m having trouble understanding.

The model is a GLTF model and I’m using the AssetManager to load it, the addMeshTask method.

I’ve also tried different methods to load but it didn’t seem to work. I’ve tried using the SceneLoader.Append method, but it gave the same error.

If anyone has any suggestion or ideas of what’s causing these issues, please let me know.


Would be great if you could share the model not loading ? This is pretty strange and I would like to address it ASAP

It is the same problem than in this post:

1 Like

Even after the update, it’s happening to me. If you have any ideas let me know. Thanks!

The npm packages and the Playground have not been updated with the fix yet. It will happen this week before friday (no exact date, sorry).