Uncaught DefaultCollisionCoordinator needs to be imported before as it contains a side-effect required by your code

After upgrading to 7.12, this error occurred physically

This is my code:

If you are using collisions you will need to import the default collision coordinator to get it to work. Are you saying it didn’t throw any erros before 7.12? what was the last version that worked?

I am normal on version 4.2。
I use vite5+vue3. And use on-demand referencing.

What should I do to implement default import?

good, that’s quite a jump in versions :slight_smile:

Import the side effect:

import from "@babylonjs/core/Collisions/collisionCoordinator"

Perfect, thank you.

1 Like