Uncaught Exception - ComputePressureObserver

We have a user getting a strange error loading a scene:

Uncaught (in promise) TypeError: Failed to execute ‘observe’ on ‘ComputePressureObserver’: 1 argument required, but only 0 present.

  • at e.observe (babylon.js:1:480233)
  • at new t (babylon.js:1:486791)

It is only happening on Google Chrome for this user and we are not really able to recreate it on our own machines. Worried it might be happening for some of our other users though.

It causes the entire scene to cancel loading. For some reason we can not seem to catch it in any sort of try/catch block either.

Any ideas what might be happening here?

hey! we did an update recently as the computepressure api change

Can you tell me which version you are on? (both chrome and bjs?)

Chrome: Version 103.0.5060.114 (Official Build) (64-bit)
BJS: v5.6.0

can you try to update to latest bjs version? I’m pretty sure I fixed that issue recently :smiley:

Will do! Might take a few days but I will report back if that worked. Thanks!!!


Hi @Vandy just checking in if update solved things for you?

We got a bit delayed testing having to get a new build out first We are actually finally getting to this in the next several days. Should know more soon.