XR mode on Magic Leap

I tested my scene using Magic Leap last month and it was working fine. Recently, whenever I enter the XR more using Magic Leap, nothing shows up. This happened for multiple pages, one of them is vanilla JS, and another is built using React. Wondering what am I getting wrong. I am using the following scripts:

        <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js"></script>

        <!-- Babylon.js -->
        <script src="https://cdnjs.cloudflare.com/ajax/libs/dat-gui/0.6.2/dat.gui.min.js"></script>
        <script src="https://preview.babylonjs.com/ammo.js"></script>
        <script src="https://preview.babylonjs.com/cannon.js"></script>
        <script src="https://preview.babylonjs.com/Oimo.js"></script>
        <script src="https://preview.babylonjs.com/earcut.min.js"></script>
        <script src="https://preview.babylonjs.com/babylon.js"></script>
        <script src="https://preview.babylonjs.com/materialsLibrary/babylonjs.materials.min.js"></script>
        <script src="https://preview.babylonjs.com/proceduralTexturesLibrary/babylonjs.proceduralTextures.min.js"></script>
        <script src="https://preview.babylonjs.com/postProcessesLibrary/babylonjs.postProcess.min.js"></script>
        <script src="https://preview.babylonjs.com/loaders/babylonjs.loaders.js"></script>
        <script src="https://preview.babylonjs.com/serializers/babylonjs.serializers.min.js"></script>
        <script src="https://preview.babylonjs.com/gui/babylon.gui.min.js"></script>
        <script src="https://preview.babylonjs.com/inspector/babylon.inspector.bundle.js"></script>

        <!-- links to the latest version of the minified glTF serializer -->
        <script src="https://preview.babylonjs.com/serializers/babylonjs.glTF2Serializer.min.js"></script>

When I got this on Quest, it resulted because an exception was thrown. If their browser is chrome based & there is a USB connector, you might do remote debugger session.

BTW, I don’t think you should need more than one physics engine.

Thanks, @JCPalmer! I’ll remove the extra physics engines.

I tried the Sphere in WebXR example but it had the same result: On Helio (Magic Leap’s browser), it shows up as a non-immersive page but as soon as I click the Immersive Mode icon, everything disappears.

Switching to the most simple example possible was right. You are probably going to need to checkout their browser’s docs.

You can try to feel your way in the dark as well. First test would be to try the same pg with 4.2. Click the menu button at top left.

If that works, making your own similar scene, you can try every 5.0 level till it stops working. There’s a can which has those.

Seems just as likely that a device update is the problem. I’ve heard that there are sample scenes try some of them. If nothing works, call ML.

Edit: On a desktop now. A quick search and found this page to try. Was built for Helios

Also, the pattern to get individual version of 5.0 is

Change the 18, to 1, and work your way up till a very simple scene no longer works. Whatever happened to BJS in that release is not supported in Helios.

1 Like

Yes! You were absolutely right. I reverted back to 5.0.0-alpha.29 and it worked like a charm! Thank you SO MUCH @JCPalmer !!