Babylon not working?

Hi guys~!!

I am having issues with opening/using Babylon with Chrome for some reason :frowning:

[1]. My current project is not loading

I have downloaded babylon module with npm, but I found out that unless I use dracoCompression, it will always try to pull from preview.babylon.com [post - https://forum.babylonjs.com/t/draco-decompression-broken/14789]

[2]. More surprisingly, I cannot even open Babylon PlayGround :frowning:

link to the PG

Screen Shot 2021-08-11 at 5.25.26 PM
Screen Shot 2021-08-11 at 5.31.13 PM

Another surprise.

I can still open my project, PG, and everything using other browsers like Safari or even on mobiles, but just not on my computer…

Does anyone know what is going on?

Thanks! Have a happy coding day~!

Hello bro
I am also having the same problem also mobile
So I think this is temporary. @Deltakosh help this problem
+that have problems : playground , Asset Libraries
아마 한국사람인거 같으니 한국어로 덧붙이자면
어제까지만 해도 되었던것이 같은걸로보아 한국쪽에 문제인건지 임시적인 서버다운인건지 모르겠네요.
그리고 오늘 2주작업한거 날려서 복구중인데 엎친데 덮친격으로 ㅠㅠ 이렇네여

1 Like

The PG is now working. Is your problem solved ?


not yet…

Is there anyone else who has been having problems with the playground?


That’s the playground you expected, right @11128 ?

I never encountered this and I’ve been busy with playground every day lately. Maybe something about your firewall .or another kind of local restriction …?

yes, until yesterday @Faber
There was no problem with the PG, but starting today, there is a problem.

ohhhhhhhhhhhhhhhhhhhhhhhhh now it is possible i can PG and assets

@Faber

PlayGround and my project are all working now.

I want to prevent this from happening though. It seems like THIS is the way to do so.

As far as I know, Draco is a way of compressing .gltf and to load a .gltf model, I need this draco thingy.

What happened to me was because my project was trying to pull draco file that is required to load .gltf, but because it is not internally located in my project, in an attempt to pull it from preview.babylon.com, there was an error.

Is this correct?

How can I put it in my project so that it won’t happen again??

Where should this go?

I just included this in the code block where I am declaring and initiating the engine, scene, canvas, camera, etc. before loading .gltf

Would this be the right way?

Thank you for your help!

Hi!

I’m sorry that you lost 2-week worth work. Really sorry to hear that. Hope you are now back on track.

Yes I am Korean. Are you currently working in some other country?

Thank you for your concern
I am working for a Korean company in Korea.

Did you somehow figure out how to prevent this error?

It seems like THIS is the way to do so, but I am not sure how I can work it out :frowning:

DracoComperssion.Configuration is a static object that you can change:

Babylon.js Playground (babylonjs.com)

(line 29)

If you import DracoCompression (in case you are using es6 imports) it will work the same

1 Like

So I can just do this?

DracoCompression.Configuration.decoder.wasmUrl = `some location of wasm file in my project`

exactly, with your own URL(s)

hmm… seen anything like this before? :frowning:

i would guess the first line is the important one. You are loading the .js file as a text/html (might be a 404?) so it can’t execute it. it should be application/javascript

hmm

it’s already a js file though. Wouldn’t writing a relative path to the wasm file work? :frowning:

the fact that it is .js is good, but your server is sending it incorrectly. and the browser can’t import this script for that reason. This is at least what the error message is saying

I tried blocking the preview.babylon.com draco request so that I can test if
DracoCompression.Configuration.decoder.wasmUrl is working, but it sill tries to pull from the website :frowning: