Image gui is covered by HighlightLayer

As shown in playground and picture, I want to draw some images on the house. I used gui, but they will be obscured by the color of HighlightLayer. I want to know how to solve it. Looking forward to your reply!



playground:https://playground.babylonjs.com/#KBS9I5#35078

hope this helps

3 Likes

Unrelated to your issue but THANK YOU for this thread, because thanks to your playground I realized that after working with 6 years with BJS I still now f*** all, because I used this custom code I made to make the plane with advanced texture to always “look” at camera

// Add observable that changes this board position
    state.scene.onBeforeRenderObservable.add(() => {
      damageBoard.position = options.pivot.position.clone();

      if (damageBoard.isEnabled()) {
        damageBoard.position.y = options?.yPosition || 13;
        damageBoard.lookAt(
          state.playerCamera.camera.globalPosition,
          rotationFromDegrees(0),
          state.cameraType === 'fps' ? 0 : rotationFromDegrees(0),
          rotationFromDegrees(180),
          Space.WORLD
        );
      }
    });

BUT YOU CAN JUST DO plane.billboardMode = BABYLON.Mesh.BILLBOARDMODE_ALL; ??? :joy::joy::joy:

1 Like

You can make the plane render in a higher rendering group than the highlight layer: Create a Simple World Series | Babylon.js Playground (babylonjs.com). Through this will make the plane render on top of every other object of the scene.

2 Likes