Unable to load from girl/warrior.glb: Cannot read property 'instancedArrays' of undefined

I use the above code to load the glb model, but it gives an error in the console. I can’t understand what the problem is. The server gives the file, I checked. The same code works in another project ((I can’t understand what the trouble is. Help

Maybe the first part of address should be not “girl/” but “./girl/”?

1 Like

Could you try changing import * as BABYLON from ‘babylonjs’ to import * as BABY from ‘babylonjs’; ???

Basically renaming the BABYLON to something else, I wonder if a conflict on the namespace might happen.

I tried, it doesn’t work :slight_smile: Thanks anyway)

Could you try ro repro in the playground or share a Github link to your project ???

I tried, it does not work)


It is not a playground, it is your own environment and playground.babylonjs.com is the way to go to quickly identify where the issue might come from.

Ok, thanks :slight_smile: I’ll do it now)

and looking at the code you provide and your index, it might cause you use renderCanvas instead of appCanvas


This solved the problem) Thank you))