WebXr Exception https

Hi everyone !
Today i create this topic because i meet a problem. I found this error code in the development windows of Chrome: “Uncaught (in promise) Error: WebXR can only be served over HTTPS

I use the 127.0.0.1 http ip. I know i can use the localhost dns for load my babylon project, but i have to make the loading fast (lot of texture, object, and dependencies). And the windows dns resolution is very very slow… I must use for production use the 127.0.0.1 ip, but i don’t know how i can do an exception of the security of webxr for my project:

I use a Pico 4 and i have to send my project on the helmet. How can i do ? I have to connect USB and launch my project with 127.0.0.1 ? Or I have to make exception on my php local server and write into the Pico http://[ip adress of my computer] on a Lan ?

So my question is: How can i load my project with overpass the webxr security for the url and use the http://127.0.0.1 or the ip adress of my computer ? (I can give more informations if you want :wink: Thanks in advance and very good day for you !

Bastien.

WebXR must be served over https. I believe, however, there is an exception for localhost, so i would first try using localhost instead of the local ip address.

Otherwise, any local server you run can use self-signed certificate and server your site over insecure https (which is fine for tests and local development). What server are you using to serve your site?

1 Like

We have only a php 8.1.8 server :slight_smile:

i am sure it has an option to turn on a secure connection (or to tunnel it locally). can’t really help with a php server, as i don’t really know it. Have you tried using localhost instead of 127.0.0.1?

Yes I already tried, but the application is very large and slow to load. We have a lot of textures and objects and when we use the “localhost” the loading goes from about 7 seconds to 40, so I have to use 127.0.0.1. So the best way is to create a self-signed certificate for https?

no way around it TBH. WebXR must be served over https.

Thanks for your help ! I will try to make a self signed certificate for 127.0.0.1 :slight_smile:

Good day to you !

1 Like