Black screen on Play button in Editor on Mac Catalina

Have installed Babylon.js Editor on my mac (Catalina). set up a basic scene - Add Cube mesh, directional light and Arc rotate camera. When press the Play button, a new “Play” window pops up with completely black content. nothing happens. this is what a console says:

Hi pantomas,

Welcome to Babylon! It looks like your scene wants to use the CANNON.js physics engine, and the Editor doesn’t know where to find it. I’m not completely sure how to install that for the Editor specifically, but Editor grandmaster @julien-moreau might be able to help you if you get stuck on that. Best of luck!

Yes, looks like that. But I dont have any physics in the scene. It is almost empty. But still I’m not able to run it :frowning: totally stuck on this issue. How can I send this message to Julien, please?

No worries, @julien-moreau the editor Guru and Daddy will help soon :slight_smile: He is checking the forum regularly.

Hey @pantomas !
Right, sorry for the delay I was pretty unavailable but now I’m back =D

@syntheticmagus is right, cannonjs is missing here (physics engine used by default) and physics can’t be disabled in the editor. BUT, I recently pushed a commit that allows to switch the physics engine and also disable physics in the scene. This will be available in the 4.0.0-rc.2 and I’m planning to deploy tomorrow.

For now I suggest that you de-add the cannonjs script in your index.html file (I think you already done) and tomorrow you’ll be able to disable physics :slight_smile:

Hallo julien, they were right, you’re genius :slight_smile: thanks a lot. I’ll wait. We are fresh beginners in babylon, trying to find the common language :slight_smile: have a nice day. Tomas

1 Like

I concur!