Build and run errors in the native playground targeting iOS

I am trying to build babylonjs native for iOS in xcode.

I started by pulling the latest from github, and successful build the project using CMake

cmake -B build/iOS -G Xcode -D IOS=ON

I opened the compiled project file

open build/iOS/BabylonNative.xcodeproj

I initially ran into some errors due to wrong iOS target, which was solved by setting the iOS build target to 17.

The problem is I still get the following errors, which I hope someone can help me solve?
I’m rather new in xcode, but experienced Linux user. So this could be a simple setting I am not aware of :slight_smile:

My compile errors from xcode:

What was the ios target before before setting it to 17? did you try to set it to 16.x?

It targets iOS 15, and if I try to build I get a lot of errors where I need to upgrade the build target.

But it seems some of the errors I got when targeting 17 is also present…

i’ve just cloned BN repo and I could build it with Xcode 15.3 (15E204a) and cmake version 3.26.3
the command to generate project:

cmake .. -G Xcode -D IOS=ON -D DEPLOYMENT_TARGET=15

Then open with Xcode and that’s it. Maybe you’ve missed DEPLOYMENT_TARGET=15`

1 Like

I had Xcode 15.2, and after upgrading to Xcode to 15.3 I’m able to build and run the playgound!
Thank for helping me out!

1 Like