Camera zoomin bug

i try to move camera to new position,and set new target & position for it;
but something goes wrong.

i try to repetition it,but it failed;
so,I tried to recreate the problem in a different way

this is my pg for it:
use your mouse,zoom in slowly,you will find something wrong

1.normal


2.zoomin

3.rotating

4.zoomin continue

Welp that’s a hard one - it seems to be related to sub meshes and thin instances. :dizzy_face: Maybe @Evgeni_Popov can help. :slight_smile:

If I had replaced the coordinate system mesh with another element (a sphere), this would not have happened

or use the coordinate system mesh,but don’t use thin instances,this would not happen also

Also if don’t use submeshes it works with thin instances (PG) and if use clones it works with submeshes (PG) and if use instances it works with submeshes too (PG). Seems like thin instances and submeshes are needed to cause the issue. :thinking:

thanks for your answer :wink:

sometimes,we always need instance way to reduce drawcall,
so clone and cerateIntance can’t resolve our problem

and,if dont’t use submeshes,the material is not we want.

so,i’ll try to import a coordinate system model(.glb),or you have another better way for it?

it seems that mutimaterial cause the problem
so,i created a shader material for three axes,but under instance way,we can’t see anything

@Blake I need to correct a mistake I made earlier,the API createInstance can also keep drawcall is 1
finally,i choose createInstance,thank you !

but the problem what i said still exist.

1 Like

The main issue is all related to the culling strategy being used and can be disabled as such: https://playground.babylonjs.com/#RL03KP#9

1 Like