Does 'ground' have an height/width limit? Trying to make a massive VR level

I’m currently trying to build a super massive VR level.

Right now, my width/height are at 10K, but I want to make it a 100K or a million. I try to increase it to those numbers, but I don’t think it gets any larger.

I’ve tried walking to “the edge” of the world, and I can get to it, so I don’t think this is a field of view problem.


There’s no real limit except for the floating point range.

So 1 million should not be a problem. However, you may need to enable the logarithmic depth buffer if you have some depth precision problems.

If you’re reaching the edge of your world quickly with a 10k-100k world size then I’d look for problems in your code, because that doesn’t sound right. I’ve been messing with a 1k square and it’s like a pretty large field (you can’t see across to the other side).

It might not be viable for your usage, but sometimes just shrinking everything else is a reasonable solution to ‘range’ problems. Depends on your hierarchy but if you have something like:

  • ground
  • world contents
    then applying a scale to world contents can give you 10x, 100x or even 1000x increase without needing huge numbers.

Hi there,

My game involves flying. So, when I’m on the ground, I can’t see across to the other side, but as soon as I’m about “75ft” in the air, I can see the boundaries.

I think when I change the numbers from 1 10 100 1,000 10,000 I see a change in the landscape, but I’m not seeing any changes in the landscape at 100,000 or 1,000,000.

Do you have any thoughts about how to debug this? I feel like I should just be able to change these values and the environment should grow accordingly?

I just discovered something very interesting! I moved my camera “beyond” the world map, and I saw that it extended thousands and thousands of feet more, but I couldn’t see it from the center. There’s some kind of massive cube that is not letting me see beyond it. I wonder what it is? If maybe it’s something to do with setting up the sky or the horizon or something. Trying to figure it out…

oh, I see, it’s the environment! createDefaultEnvironment is messing with my ground!

yup it indeed creates a ground and a skybox for you. If you do not want them, you can easily turn them of in the createDefaultEnvironmentOptions

Sounds like you’ve got it, but - if Babylon has this option - also make sure the camera ‘far clipping plane’ is not set too close if you want to be able to see huge distances. Note that (in Unity at least) this can cause problems with accuracy of things that are very close to you.

Yup totally, it is the same in babylon.

Early on, that was a problem, and so I fixed it. I think it was the first thing that tripped me up.

1 Like