Fullscreen UI, disable components


How can I properly disable components of fullscreen UI? Property isVisible just hides the UI but it’s still enabled. So I cannot interact with the scene, even when the components are invisible or disabled.

Ok, so I realized that I had one top parent grid (for a nice layout), and that’s why I kept having the issue - no interactions.

Once I removed it, hiding the components works as expected. This means I have to rebuild my UIs.

It works for these:

Or just set isEnabled to false for the top parent - in my case.