Gltf-transform etc1s compression not working on windows machines

when we KTX compress our glb files we see the following console error in chrome, firefox and edge on windows machines when trying load thee glb models. The same glb files work fine on mac machines. We see this both with on the BabylonJS 5.0 alpha and 4.2.0. I’m not sure if this is a bug or user error. Any help anyone can give would be greatly appreciated. Here is the gltf-transfrom usage page: CLI | glTF-Transform. Here is the gltf-transform command we use: gltf-transform etc1s input.glb output.glb

babylon.js:16 Babylon.js v5.0.0-alpha.21 - WebGL2 - Parallel shader compilation
babylon.js:16 Uncaught DOMException: Failed to execute ‘postMessage’ on ‘Worker’: Data cannot be cloned, out of memory.

Welcome aboard!

Can you provide the glb file that is throwing errors? It will be hard to help without it.

On which device are you testing it?

Thanks for the reply. The .glb is large, I’ll try and create a simple example then upload. The thing that is puzzling is that it works fin on multiple mac machines, it even works fine in a parallels windows setup running on a mac. It fails with the error above on every windows machine we have with the above error. When I run gltf-transform validate on the compressed .glb, I see the following in the ERROR section which could be related. I don’t see the same error when I run validate against the uncompressed .glb which runs fine on windows machines.
│ ACCESSOR_MAX_MISMATCH │ Declared maximum value for this component (6.964391268015478e+37) does not match actual maximum (Infinity). │ 0 │ /accessors/463/max/0 │
│ ACCESSOR_ELEMENT_OUT_OF_MAX_BOUND │ Accessor contains 3 element(s) greater than declared maximum value 6.964391268015478e+37. │ 0 │ /accessors/463/max/0 │

You should probably try to post an issue in the gltftransform repo regarding the errors you get.

Also, did you try with another gltf viewer (like

Thanks, I will post on the gltf-transform repo. Yes, we’ve tried that gltf viewer. Again it works on mac machines but not on windows machines. Same with the BabylonJS sandbox.