Ground from Heightmap is Inversed

Why does the ground created from a heightmap is generated but it is reversed in the z axis?

Like if by default the z scale is multiplied by -1.

The problem is when I apply the same heighmap as the emissive texture of the material. it appears reversed.

Is it possible to apply the z scale as -1 and then “apply it” so it is 1 but with the changes made. Then when a material is applied it shows it “correctly”?

What do you mean by “reversed in the z axis”? Can you provide us with a playground example?

I’ve tried setting the same height map texture as the emissive texture and it looks normal: Heightmap and emissive texture | Babylon.js Playground (

1 Like