How to turn off reflection from the environment?

I have inserted a 3D model of a room, the materials and structures are already in place, I want to turn off reflection on the material from the surrounding environment without touching the objects of the room.

this is the function I use:
BABYLON.SceneLoader.ImportMesh(

    "",

    "assets/material/object/", "RoomExport.glb",

    scene,

    function (newMeshes) {       

        scene.activeCamera.alpha = Math.PI / 2;

        engine.hideLoadingUI();

    }

);

You can try
someMaterial.disableLighting = true; - PBRMaterial | Babylon.js Documentation

1 Like

The problem is still not resolved

You can set scene.environmentTexture = null if your environment is set at scene level, or material.reflectionTexture = null to disable it for a specific material.

1 Like

While fairly indirect, and for others searching in the future, changing the material to ensure roughness is set higher, & metallic is set lower. Smooth, metallic things are shiny, and thus reflect. Seems like your material is wrong if it does not reflect when set this way.

BTW, clearcoat might also apply, but I do not know for sure on that one.

2 Likes

Here is the PG where one can check different PBR reflection options - https://playground.babylonjs.com/#8MGKWK#374 - have a look at wood material, which has no reflections.

The best way is to load your model into Playground so we won’t guess about it - Using External Assets In the Playground | Babylon.js Documentation

From my point of view, you may try to adjust metallic/roughness parameters as in @JCPalmer advice. Another simple way is to change your environment texture to another one which will give you more dissipated lighting.
At the moment you have studio lighting texture
image
You may try other HDR textures from library - The Texture Library | Babylon.js Documentation - or find or make you own.

2 Likes

I tried this and it was successful, thanh you very much ?