Remove Shadow Reflection When scene.renderTargetsEnabled is false

Hi all,

Is there a way to get rid of mirror reflections when “scene.renderTargetsEnabled” is turned off?


Welcome aboard!

If you want to remove the reflection for some materials, you should not set scene.environmentTexture and instead set the reflectionTexture property of the materials you want to be reflective.


I didn’t set the scene.environmentTexture, but the reflection appears when the render target is turned off. like in this.

Why did it happen ?

When I turn it back on, there is no reflection.

I think we will need a repro as I don’t repro in this PG:

The ground has a material with a reflection texture set and not the sphere. When disabling the render target rendering the display does not change, the sphere does not get reflections.

1 Like

I have found a way to get rid of it. The glass’s texture level is set to 0 and the reflection disappears

textureGlass.level = 0