Installation version bug

I installed all babylon versions as 5.27.0


It is found in the yarn.lock file that the version of gltf2interface is 5.28.0,This causes an error in my model loading.

Is the fixed version installation invalid?

Hello @brightMoon.
It looks like you’ve fixed the versions to 5.27.0 for every other package and not for this one.
Can you try changing your package.json to have
babylonjs-gltf2interface": "5.27.0",
and run yarn. Then check if it’s ok?


fter a try, I still report the same error

You have both versions installed, I don’t know which one is actually used by your application.
Can you try removing node_modules and running yarn again? Or even removing yarn.lock.
Just to be sure that you have fixed 5.27.0 version installed

Node has been deleted_ Modules package and deleted yarn.lock. Version 5.28 is installed in babylon loaders. But I’m from node_ The babylonjs-gltf2interface viewed in the modules file is version 5.27. So it’s strange

Maybe @RaananW will have some idea what is going one here :smiley:


can you share the list of dependencies as well? We have a list of dependencies on each package. The packages SHOULD have the dependencies set as peer dependencies using ^5.22.0 as version, meaning - if you have a package installed that meets this, it should be used. But what you are saying is that one of the packages doesn’t follow this dependency definitions, so it would be great to know which one.

You can also use the overrides key in your package.json to force a version. This is not a scalable solution, but will work great in your case. (package.json | npm Docs)

Setting overrides is invalid.

 "babylonjs": "5.28.0",
"babylonjs-gui": "5.28.0",
"babylonjs-loaders": "5.28.0",
"babylonjs-materials": "5.28.0",

Are you able to share your project, with the package and package lock files?

1 Like

That would be a great help