Loading .gltf file working on the playground, but not on my local setup

Hello all, first time asking a question!

I played a bit on the playground and everything worked perfectly. I wanted to switch to my local environment so I can work from there but I had no luck.

So here is the simplest playground, and as you can see, the model loaded. Babylon.js Playground

But when I try to load that same file on my local, it’s not working.

What I tried:

  • To load the file from my system,
  • To load the file from the same link as in the playground
  • To set undefined, null, “”, [] for meshNames

The only difference is when I put [] I get an empty array in meshes, but for all of the other examples, i get an error:

The file itself was created in Blender and exported as gltf.
More or less the same code was used in my local environment.
These are the only differences in comparison to the playground:image

What I understood is that if I don’t pass anything, or pass an empty string as the first param, it will load everything, but for some reason, it’s not doing that.
I’m using webpack to build my app, but I’m loading Babylon as a separate file since webpack takes too long to compile Babylon if I import it. I’m using a file from this URL: https://cdn.babylonjs.com/babylon.js

Thank you all in advance!

are you also referencing the loaders in your page ? it is a separate script

1 Like

No, I am not using anything else.

Is this what I should use? Use the glTF File Loader Plugin - Babylon.js Documentation

It is! thank you very much!

1 Like