Merging submeshes

hmm is there any thing im doing wrong here, i’m trying to merge submesh clones as one, i’ve tried with the native mergeMeshes function but it’s not working too

https://www.babylonjs-playground.com/#AISC73#1

BABYLON.Mesh.mergeMeshes(“merged”, k, scene)

is the real function, I was messing around with it for a second then a realize the callback is dropping an error. We would need to solve that before proceeding.

1 Like

for 32bitsIndices, i tried this mergeMeshes(“merged”, k, true, true)

still dropping the same error

Im dumb… I did not see you had defined your own mergeMeshes function.

give me a second.

but that still does not explain why BABYLON.Mesh.MergeMeshes(…) did not work as well.

https://playground.babylonjs.com/#935ZDW

Never had a valid scene defined.

1 Like

:smile: my bad! i must have been so stressed today, i finally got it working

so i just needed to mirror the mesh by baking the transformations and then merging the baked mesh, that’s the only way i’ve got it to work else it will return an error. In case anybody is stucked with something like this:
this is my solution:

https://www.babylonjs-playground.com/#TEIWLR#1

Dude I feel you! Sometimes when we get frazzled and look over things that we would get like 99% of the time, but this time you go completely blank… I can’t tell you how many times Delta has pointed out something super simple to me that I was missing to make something work and then in retrospect it makes you kick yourself a little…

2 Likes

:sweat_smile: exactly!!

1 Like