No shadows in GLTF scene

Hi guys!

Will you please tell me how can I get proper shadowing in GLTF scenes? At the moment I have no shadows at all in the scene I export from Blender, no matter what lights and lighting settings I put there. Do I need to use shadow generators for them anyway to receive shadows?

As for me it would be great if all lighting settings along with shadowing would have been taken from the scene itself, because all those settings are already there, including shadows casting and receiving. So please tell me if there is any option to derive proper shadowing from a GLTF scene itself without using shadow generators or do I have to use them anyway? What other options of shadowing are there to use?

Hi @artteq

Here is another forum post about shadows and GLTF: Struggling to cast a shadow from glTF to ground

Also feel free to share the specific playground you have and I can take more of a look.