Ready Player Me Model : Error when changing animation <SOLVED>

I am using an approach similar to loading animations as shown in a couple of threads however there is no information available addressing my particular error related to changing an animation of a Ready Player Me model.

The error I get is:
runtimeAnimation.ts:349 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘getRestPose’)

I have seen this error posted and some explanations of how to fix it, but none seem to pertain directly to my case.

For example, here , it was pointed out that the armatures had different names. All the armatures in my example have the same name.

I thought perhaps there was something different in the bone hierarchy, but those seem to be the same as well.

Here is the PG with the animation source .glb given the name OH_MY.

Any help with this matter would be greatly appreciated.

Here is a PG illustrating this issue but without showing the animation source .glb:

Thanks @Evgeni_Popov ! Your statement, “You need to return a valid target object in the function you pass to the clone method:” steered me to the solution!

Here is a PG with the fix in place.

Hi @ArrayBuffer
Here is a simple demo using RPM blending animations

Another one using Face Morphs

Hope it helps!


Thanks @DRLeria .

Btw, you can mark DRLeria’s answer as a solution, that will show the question as solved :slight_smile: I did it for you here but it’s a tip to remember