Reflections rendering black using env, any thoughts?

Hey all,
I have been using an env that I created using So far it has worked great. The problem I ran into today, that I cant seem to figure out, is that when creating a new env it “lights” the scene ok but the reflections are black. I even tried the original hdr that I used to create the older one but no luck. The way I am creating them is by simply dragging the hdr into the sandbox and then saving out the env. I am guessing it is just a button or checkbox I am missing? But any help here would be greatly appreciated. :slight_smile:

This should totally work so something is really wrong there :frowning: sounds like a bug to me

Could you share a repro of this model in the playground with your env ?

Thanks Sebavan, the mesh is actually being dynamically created and pretty complex. However, this weekend though I will try and reproduce the problem on the playground.

Have you tried creating your env directly from the IBL tool instead of the sandbox? It would at least isolate the problem a bit more if it still happens

Wow, jelster. That worked. And thanks for pointing out that tool. I had not used it before. :slight_smile:

1 Like

So the issue is that you are using version 4.2 of babylon and sandbox will generate files for 5.0 where the ibl tool is still creating the old version :slight_smile:

Ah gotcha, I will take a look at which version I am using. Thanks again.

@sebavan. As I expected you are correct I am using 4.2. To be specific I am using node.js and babylonjs - npm. Seems it has not caught up yet version wise. Or I am doing something wrong :wink:

You should install with npm install babylonjs@preview to get the latest preview :slight_smile:

Ooo, very cool I will try that. Much thanks. :slight_smile: