[Solved]Warnings in version 4.1 using instantiateHierarchy

getting warning for instantiateHierarchy like this

BJS - [10:16:26]: Cannot set property isWorldMatrixFrozen of # which has only a getter

its bug or missing feature ? have hierarchy with TransformNodes + instanced / cloned meshes for mesh I call instantiateHierarchy.

doing something wrong ?

thank you

Are you getting this every time you are using it? could you reproduce quickly on the playground?

yes very time, will try to make PG a bit later


@RaananW sorry for big delay
here is PG
with warnings

yep, seems like properties are being set on objects with only getters (instances).
Want to create an issue in github? the general solution would be to add getOwnPropertyDescriptor and check for writable or set , but maybe we can know beforehand that this object’s properties cannot be set.

I’m on it…I must have an issue in the way I clone a hierarchy containing instances


Will be fixed by next nightly

1 Like

Thank you @Deltakosh, side question, I reported some bugs for 4.1, some are already fixed, some I still try to reproduce in PG, how will npm release happen ? it will be fixed in for 4.2.alpha already or there will be 4.1.X releases ? as these bugs stop me from using 4.1

They will all be released in 4.2 alpha :slight_smile:

@sebavan thank you will wait for npm release then :slight_smile:

alpha 3 is out :wink:


@Deltakosh still don’t see it on npm :confused:

will check that

Actually npm install babylonjs@preview is installing version 4 already :smiley:
There is a bug on npm website

Thank you @Deltakosh will work for @babylonjs/core as well?

yes all of them

@Deltakosh nope still get error from npm Couldn’t find any versions for “@babylonjs/core” that matches “4.2.0-alpha.4”
as its dependency for inspector package

npm install @babylonjs/core@preview installs 4.2.0-alpha.2

It should be ok now (it was a npmjs cache error)

hm, it still shows old version for @babylonjs/core:

1 Like