AdvancedDynamicTexture CreateForMesh weird error

Hi I’m currently using the AdvancedDynamicTexture’s CreateForMesh function to change the texture but when I try to apply it to a model we have but it gave an error:

You’ll also notice that the screen’s (the middle screen) texture was updated with the left one:

One thing I notice is that the left screen and the middle screen has the same material. Could that be the issue?
I’ve tried to replicate it in on the playground but there, it seems to work. (It might be because I removed other components of the model and that’s why it worked?) But a more detailed reason would be helpful as well.

Any help on this is greatly appreciated. Thanks so much!

Would it be possible to add the missing components (or a simplified version of them) one at a time and see when and if it fails?

Hi @JohnK I’ll still need to confirm but unfortunately it might be hard to do so. Although one thing I noticed is that for the left screen the material is PBR while the middle screen is Standard but I’m not quite sure if that is helpful.

Make sure you are really passing a proper mesh to createForMesh: a mesh does have a material setter so it should work.