Animations play question

I find that the annotation for animationGroup.restart is:

But it will not actually reset, because animationable’s restart will not restart animations from key 0.

Interesting find

Feels like that method should be called “unpause” rather than restart. There is a “reset” method though, that should “restart the animation from the frame 0”, maybe that comment in the code just got misplaced during the process, plus the naming “restart” for unpausing might be a bit confusing. Basically, restart method is just opposite of pause method.


Good catch! Want to submit a PR correcting the comment? Unfortunately changing the method’s name is harder because of backwards compatibility

1 Like

Of course.I will try to submit a PR. :grinning: