AppendAsync cannot Load Blender Model Animations

I’m Japanese, Sorry for my poor English.

I use Blender 2.93 & Babylonjs 5.4.

Loaded Model can be displayed.
But Cannot Load Animations.
I missed Export Model Settings? or Failed to import Model?
Help me, Please.

This is part of my code.

let game = document.getElementById("game");
let engine = new Engine(game, true);
let scene = new Scene(engine);
let fileName = "mini.babylon";
let meshName = "mini";
SceneLoader.AppendAsync("model/", fileName, scene)
            .then( async() => {
                const mesh = scene.getMeshByName(meshName);

                console.log(mesh.animations); // this is []

Welcome abroad! Maybe you try to check scene.animationGroups.

Thank you, @tanpopo!

scene.animationGoups is also, []

This loaded model can’t be moved with “movePOV”. I don’t know if it’s related

This is babylon exporter’s settings & Object Hierarchy.

Always check the .log file for messages and export details. Looks like you are exporting skeleton animation. The log file should show this, in thiscase.

Yes, @JCPalmer .

I have log.
animation breath has been exported.

processing begun of skeleton:  mini_arm, id:  0
processing action breath:  in[1 - 60], out[0 - 60]

Ok, then the animation is on the skeleton, not the mesh

I found Skeletons’s animations registered in scene.
I tried

scene.beginAnimation(scene.skeletons[0], 1, 60, true, 1);

But, This is failed.
animations property is undefined in skeleton root.

Bones in skeleton have animations.
So I tried

scene.skeletons[0].bones.forEach((bone) => {
  scene.beginAnimation(bone, 1, 60, true, 1);

But This is failed, too.

I could show Skeletons with Debug.SkeletonViewer.
Skeletons is moving, But Mesh is not following to skeletons.

I Can show this Mesh is Moving on blender Application.

I was exporting Armature Modifier Applied Model.

I tried to export model with Armature Modifier.
I got this error.

Mesh: body has un-applied transformations.  This will never work for a mesh with an armature.  Export cancelled

Model Mesh & Armature’s Position x,y,z, Rotation x,y,z are All 0. Scale x,y,z are 1.

Comment out this error part from plugin scripts.
I get this model.
Armature(skeleton) size is too big.

I solved Size Problem.
I don’t know why but Model scale was changed after I used export plugin.

I tried Simple Box ,too;
This also unfollow to born;

this red born is get by scene.getMeshByName.