Shouldn’t this function return the appended scene instead of void?
It’s marked as @experimental. I’d like to know what are your intentions with the return type when it gets to production. Could it return the scene with only the appended assets? If it returns the current scene with the appended assets I see that there is no reason to return the scene.
If it returns the current scene with the appended assets I see that there is no reason to return the scene .
Yes this was pretty much the rationale. With the original SceneLoader.AppendAsync, passing in the Scene was optional, and so it would return the Scene that the asset was appended to. With the new appendSceneAsync, the Scene is a required param, so there is no reason to return it.
Could it return the scene with only the appended assets?
Do you mean returning a different Scene instance that only has the appended assets? If so, then I would say the desire to have this type of behavior is why AssetContainer was introduced, and for this scenario, it probably makes more sense to use loadAssetContainerAsync. But let me know if I’m misunderstanding your thinking here!
It’s marked as @experimental . I’d like to know what are your intentions…
At this point, I don’t think we have an intention to change anything else about the API, aside from possibly changing the casing (e.g. LoadAssetContainerAsync) since that is more consistent with other module level functions in Babylon. But happy to hear any feedback and see if it makes sense to make other changes!