BabylonJS MeshLine - a port of THREE.MeshLine

This unfortunatelly doesn’t solve the problem because core/GreasedLineBuilder creates and assigns the material automatically to the mesh based on the pbr: boolean option value, so there will be still a materials package dependency in core. :frowning:

@roland Yup I am mostly thinking of recreating your modification of PBR in either material plugin or built in which prevents the need of customPBRMaterial.

Can you point me back at your custom pbr material so that I could see how to migrate it ?

1 Like

I will rewrite it as a material plugin then, it seems to be the best choice. I’ve planned to get familiar with the material plugin anyway :sunglasses:

No need to steal your precious time for now. :face_with_monocle:

Thanks!

2 Likes

I love the attitude !!! Please do not hesitate to pick at me or @Evgeni_Popov if you need anything !!!

This feature will be awesome !!!

1 Like

I already have the material plugin, I upgraded BJS to 5.43.1 and wanted to make some test but this started to happen:

Any clue?

EDIT: and it seems that some React related packages are messing with my Vue code :smiley: :smiley: Investigating…

EDIT2: It seems it started to use canvas from React , wtf… :smiley: It is affecting my previously working code as well

1 Like

Ohhhh Huggggge !!!

About the first one, @Evgeni_Popov fixed it today I believe, Let s check if @RaananW can publish a new release Wednesday.

About the second I wonder if the first one does not break it all :slight_smile:

1 Like

Dude, my whole project is behaving pretty weirdly :smiley: so maybe it’ll be a good idea to wait until:

and check whether this is not really the case:

Thanks!

A new version was released a few hours ago. should be fine now :slight_smile:

3 Likes

Hello!

Thank you! The first issue is gone but the second one is still bothering me. Any idea how could the React canvas component get into the Vue JSX page?

Sorry, no idea!
But i’ll be help to debug it together with you, if you can share a working branch

1 Like

Guys, I was trying to get it working the whole weekend :smiley: but something in the vertex shader is still preventing to render anything :smiley: I’ve tested the material plugin just with the fragment shader, the plugin is in place and it’s affecting the material, I’ve visualized the vertex attributes, they seems to be ok, the uniforms as well but still not a single face is getting rendered. Just wanted to let you know, that I am on it :smiley: but fighting and loosing for now… Just one question. @sebavan @Evgeni_Popov PBRCustomMaterial vs Material plugin on a PBRMaterial, do I have to expect differences on the shaders? My vertex shader is working well with the PBRCustomMaterial but produces nothing with the material plugin + PBRMaterial.

Today I will compare the compiled shaders with both approaches and hopefully I will find the issue :metal:

Thank you!

1 Like

Thank you, this is very kind of you! :metal: However I will try my old trick at first to create a new project and copy the files one by one from the existing one to the ‘virgin’ one. I am pretty sure I can catch the moment where the problem pops up (I’ve upgraded not just BabylonJS but Node as well so only God knows what is really causing the problem). Anyway, is there a programmer’s god out there? :smiley:

1 Like

No, the shader code should be the same.

Perhaps this part of the document can help you identify your problem?

@roland do not hesitate to share a repro if you need us to have a look

1 Like

i have a Vue project with same issue. there is an express server that uses react server rendering in same project… React is expecting “className”. At least on my side the errors can be safely ignored - i should probably spend some time looking into it!! :smile: does not look Babylon specific though…