Babylonjs source code running error

I downloaded the source code in git:GitHub - BabylonJS/Babylon.js: Babylon.js is a powerful, beautiful, simple, and open game and rendering engine packed into a friendly JavaScript framework..
I used npm i .
Then use npm run start.
prompt error:

How should I run it successfully?

Hi @1774132125 , welcome to the BabylonJS community!

Sounds like it is related to this issue they were having yesterday: ktx2Decoder from preview site has gone missing

It’s not much consolation but this is the first time I have seen an error like this.

Thank you for your answer, but it doesn’t seem to be the same problem. I just reinstalled the dependency package, and there was the same error when I started again

I just tried with pnpm install and I got:

 ERR_PNPM_FETCH_404  GET https://registry.npmjs.org/@dev%2Fbuild-tools: Not Found - 404

@dev/build-tools is not in the npm registry, or you have no permission to fetch it.

No authorization header was set for the request.

I don’t know what your error was @1774132125 as in your message, for me, it just says:

@Delta should we be able to run npm install on a local clone of the BabylonJS repo? Trying to visit npmjs.com/@dev/build-tools gives me a NPM login page. This may be a different problem to the one the OP is posting about.

Cc @RaananW

We support npm 7+, preferably 8+. I haven’t tried pnpm, but it should behave just like npm (i would assume).

@dev/build-tools is an internal package, located in the repository. It is being compiled when you install the dependencies, since it is needed when working with the workspace.

I haven’t tried (pnpm I). I did not find any installation errors with (NPM I). When I run (NPM run start) or (NPM run serve -w @tools/babylon-server), open the page generated by the server. He will report an error and cannot open it normally

Uploading: 111.png…


打开页面后

Can you run

npm build -w @tools/ktx2decoder

and try running the server again?

Better yet, run
npm run build:dev

And then try, or even

npm start

Thank you for your reply. I installed your installation steps, but there are still problems. I recorded a video.

can you share the system you are working on, the npm version and your node version? what typescript version is being used when you run those commands?

I doubt those npm warning are somehow related, but something seems to be compiling incorrectly. I would make sure my npm configuration is correct. again, not sure what these warnings mean in that context. And not sure how they are related.
I have never experienced that, nor any of the other members.

Thank you again for your follow-up reply. I use windows10 64bit and…

I do have a feelling like your npm is configurined incorrectly, especially because of this global configuration. The Babylon’s repository is using typescript 4.6.x, we haven’t upgraded to typescript 4.7

Thank you for your help, I have run successfully. How do I get to the ‘playground’ page and the ‘sandbox’ page?

Is this the right address?

no, it is not.

Do you want to run a single playground, or do you want to run the babylon playground itself?