Black object on merge meshes

Hi. I’m haveing an system for creating routes based on some points which i’m getting from server.
Now this work almost as expected :slight_smile:
If I’m using simple lines then corners go outside of path. eg
So i tried to round them by using 2 poligons on ends of line, and at the end merge them.
This is working too, but for few of them I’m getting a completly black object, even if I’m trying to add material on it, and I cann’t explain the reason. I suspect is something with uvs on merge. eg

I tried to simplify as much as possible to expose better my issue.
ps: final result.

Problem solved
What i did is instead of merge wires at given position, I merge them at 0,0,0, and after this move them to the specific position

But still have no ideea why it didn;t work from the begining :slight_smile:

Hi MarianG,

From a quick look, it looks like your normals somehow got reversed on one of your meshes.

I’m not exactly sure how this came about, but at the moment it looks like it might be a bug (or at least an unexpected behavior) in MergeMeshes(). In the Playground I linked to, the only thing I did was force the mesh to recalculate its normals after merging, which seems to resolve the visual issue.

Again, I’d need to look closer to be sure if this is a bug or just a bizarre behavior of MergeMeshes(). @Deltakosh, does this look like a bug to you?

1 Like

@syntheticmagus thanks for the interest on this issue.