Bug with Sandbox


#1

Hello there i am new to Babylonjs

I have a problem with the sandbox. I cannot figure out a way to load the textures for a model.

I have spent more than 5 days trying to figure out what i am doing wrong but i simply cannot find a way.

My model is a gltf format.

What kind of further information should i provide to you to fix that?

All the best. Theo!


#2

When you drag&drop your gltf file, are your textures (and also gltf .bin file) dragged too?

[edit]
quick example, but with .babylon file
img


#3

Yes i tried that. And nothing really happened.

Your example is working locally ? I mean the sandbox


#4

Nope I run the sandbox from the website https://sandbox.babylonjs.com/


#5

Quick questions because i am a newbe with babylon.

Do you believe that this may happen because i use pngs? Because i can see that you have only jpgs there.

Also may you please be so kind and inform me if i can do export a babylon scene from blender ?

Thanks a lot for the info so far mate.


#6

I just tried, just to be sure, with some format (glb, gltf, babylon, textures as jpg or png), it works just fine.
So we will need more info from your model, 'cause it’s probably not a BJS issue.

Try with an empty scene and a single cube using a single material using a single texture just to be sure :wink:

And which format are you exporting from Blender? .babylon or .gltf? Anyway, you probably have to take a look in these pages:


#7

I tried with a simple cube that i created. I used then blender to export to gltf. Then i tried various textures to be imported with it. I really cannot figure out what i am doing wrong. I checked these pages of the documentation as well. I am pretty confident that i did not miss something about this subject.


#8

Share us your blend with your cube, I will take a quick look (are you using Blender 2.7?)