Cant find the loaded 3d model in the scene

Hi, i tried using a 3d model, but it seems like it is not being loaded in the scene? Can someone help?

This can happen for so many reasons. Scaling would be one of them. Camera position could be one as well. There are many other reasons!
If you can reproduce that on the playground I am sure we can find a solution very fast

How do i load mylocal file in playground?

this might help Using External Assets In the Playground | Babylon.js Documentation

Has your question been answered?
In short, the answer to ‘how do I load local files in the PG?’ is: You don’t :wink:
In fact, you have two choices:

  1. Use the (online) PG and upload your files from a ‘secure source’ as per the link shared above by @sebavan – or –
  2. Install a local version server as explained here

plese have a look at it here -

i used the same code in my project… but its not loading…

Even in the playground… its taking 30 sec to load

Hi @Manish_Michael

Line 7 indicates Path
Line 8 indicates File

line 7: “”, //PATH
line 8: “linde_l12_ac_body.gltf”, //FILE

Thank you, i added that code in my project. but its still not working

Seems to be working as expected:

Available Mesh SeaGulf | Babylon.js Playground (

1 Like

Sure, it seems to be… but cant find the scaling,position property. How can i fix that?/
When i console the mesh, i cant find them

Seems to work as expected as well:

Available Mesh SeaGulf | Babylon.js Playground (

Have you read this doc page(s)?

Yes, i did… little confused with variouse loading functions… APpend, load, importMesh etc,

Screenshot doesnt have these much arrays. Im loading it from the local

Cant find the scaling property

It does feel like both scenes and the functions you are using are different. I assume you are using the Load function and not the ImportMesh function, as the first variable you are getting is the scene and not the meshes. You can always use scene.meshes in the success callback, or work the same as the example in the playground which will provide you the meshes you are expecting to see.

Well, they all have a use and you should may be start with reading this section of the doc and eventually watch a couple of videos. There are in fact more of these such as ‘async’ and relying on promise. I know it’s a bit hard in the beginning but in the end, you’ll find all of these to be very useful in a project.

I’m afraid to say ‘scaling’ is just ‘scaling’ :wink: as in:

mymesh.scaling = new BABYLON.Vector3(0.5, 0.5, 0.5);

If you did it like this and does not apply to your mesh, then I’d say it’s likely that you did not select the mesh correctly (select the correct mesh).

Im using append method because, im calling the 3d obj from local… not from the dropbox

I was confused with the first and second variable. Thank you for clearing it :slight_smile:

1 Like

That doesn’t matter. You can still use importMesh even in a local environment (as far as I know).
Please correct me if I’m wrong.

1 Like