Disable vertex colors when rendering mesh that has them


I have a question: I have a mesh that uses vertex colors for something data related (offseting vertices etc). I don’t want to show the vertex colors when rendering the mesh using a StandardMaterial from Babylon.

I tried using this to disable the vertex colors, unfortunately didn’t work.

material.useVertexColors = false;

I don’t have the experience to write a custom shader that has all the lighting calculations etc where I overwrite the vertex colors to white when rendering. (Unless the standard material source is somewhere available? Which might enable me to do it myself)

Is there another way how to ignore the vertex colors when rendering?

Thank you!

Edit: The mesh I’m using is the same as described in this topic: Sorting of mesh with vertex colors and custom shader - #4 by Evgeni_Popov

Hello! Can you share a Playground with your mesh so it’s easier to check please?