Error when trying to use compatible versions (according to docs) of Babylon React Native and Babylon.js

After trying to upgrade our Babylon React Native app to newer, compatible Babylon.js, I get the following error on every app restart:

Yet the Babylon React Native readme says that 1.63 and 6.14.0 are compatible:

I found this closed issue reporting the same problem on older versions, but nuking node_modules and resetting the yarn cache didn’t help:


Indeed, there is a mismatch in the documentation.
1.6.3 is stuck with 5.42.2
I can kick a new build today with babylon.js version 6.14.0 if it helps you.

Is it possible to bump to latest 6.30.0? If not, yes 6.14.0 would be good. Thanks @Cedric

I’d need to do tests for 6.30 so it might take a few days.
6.14 has been tested so it should be available in a few hours.

1 Like

Ok 6.14.0 sounds good.

Looks like a 1.7.5 package has been released without a release:

it should work with 6.14.0. let me know if it fixes your issue

I’m kicking a 1.7.6 version anyway

just released

1 Like

Thanks @Cedric . I’ll try it out today!

Thanks @Cedric . I tested 6.14.0 and 6.30.0 with your new builds and all good so far! :+1: