FreeCamera Movement is busted in PGs?

Just go to the default scene and tap the arrow key forward or backwards.

Yup definitely looks like an issue but I can fortunately / or unfortunately not repro locally.

@PolygonalSun could you try as well to repro ?

@Pryme8 would be great to know the browser version you are using just in case.

@sebavan I am unable to repro it with Edge/Chrome, Firefox, or Safari.

@Pryme8 does anything pop-up in the console?

nope, no errors and let me check Chrome version.

This just started today or yesterday I noticed.

Interesting and might be a fixed bug in 94

Could you try to update ?

Nope that did not fix it.

Unfortunately it looks related to your environment :frowning: as I tried without success on several machines. This is really strange

Weird. Yeah it does not do it on canary or Firefox for me.

It’s almost like the events are not all registering.

It might be worth throwing in a couple of event listeners for each of the key events and seeing if they trigger and maybe comparing it against what comes from scene.onKeyboardObservable.

This is still a thing for me? Except now the arrow keys don’t work at all.

Is anyone else having trouble using the arrow controls in a standard PG on Chrome:

Everything works perfect on Canary and every other browser.

If this is only me having this happen then frikin nutty.

I’m getting very sporadic responses, let me record a video really quick.

So it only fires a OBS if I hit an arrow after clicking (and every time). Plus it seems to be releasing the keypress before doing anything.

I have the same version of Chrome and it was working for me. Let’s get some more people to try and see what they’re finding. Hey @sebavan, @carolhmj, @Cedric, @RaananW, @bghgary, @syntheticmagus, @msDestiny14, @Evgeni_Popov, could I get a few of you to try and see if you can repro this?


I’ll try!

1 Like

@Pryme8 Just to be sure, did you try force-refreshing with Ctrl+F5? I think there was an input bug that got fixed yesterday, so just in case there’s dead code in your cache it might be worth forcing the refresh if you haven’t already.

1 Like

Also have the same version of Chrome, tried and couldn’t get it to reproduce.

Nope no go. This is really nutty.

Let me see if I can reproduce on a local thing. Maybe my environment is broken?

Works fine for me also. Maybe try an incognito window, a different browser, or open the dev tools and empty cache and hard refresh (via right-click).


It for sure happens in no other browsers. I even uninstalled chrome and reinstalled it. I have also tried all the cache and hard refreshes.

Starting to think I just have cooties.

What about plugins? Could there be a plugin that would be interfering?

Maybe, I’ll double check. I did a fresh install but maybe the plugins came with my account.