Geometry looks bad after using Draco compression

I export a glb file from 3DS Max with BabylonJS tool, the geometry is a bit out of shape after using Draco compression.The shape is totally fine without Draco, but the file size is too big,almost 7 times bigger.
Any idea to solve this?
My BabylonJS settings are below, it does not matter if I check the ‘Try to optimize vertices’ option, the result does not change at all.

Pinging @bghgary but I feel like you can already create an issue on the exporters repo and @Guillaume_Pelletier will have a look :slight_smile:

If you can share the model so that we can repro, that would be helpful.

Draco compression is lossy, so there will be some degradation in quality. Can you try exporting to GLB without Draco and then use gltf-pipeline to compress with Draco. That will rule out some things.

Draco also has a compression level setting (0-10) that isn’t currently exposed. By default it is 7. Try different settings with gltf-pipeline to see if it helps at all.

Sorry, I can’t share the model file.
I have already solved this with gltf-pipeline and FBX2glTF.
The major problem here is the default property draco.quantizePositionBits in BabylonJS plugin is too low, and there isn’t an option to modify.
I change this to 20, then everything is fine.
The compression level does not affect the geometry at all even set to 10.
THX for the help, really appreciate it
By the way, model export from this plugin also got normal problems, the color looks different from FBX file and not good.I’m using FBX now, so I didn’t look into this

1 Like

We should probably expose some settings for Draco, both this and the compression level. Do you mind filing a feature request?

1 Like

Sorry, IDK how to do this :joy:

Just create an issue: :slight_smile:

OK, it’s done.
I’m thinking, is it necessary to create a normal issue, too?
I modified almost every options related to normal and also changed different type of materials, but none worked
I’m not quite sure it’s a normal issue, but looks like one