Sandbox can not export .babylon of .glb when .glb uses draco mesh-compression

I export my model to .glb in blender 2.8. When I am using the draco mesh compression, I can watch the model in the sandbox and lets say tune the materials, but not export to .babylon.

Without using draco compression at the export from blender, I can export the model to .babylon from the sandbox as expected. I dont know if there are reasons for this or if it is a bug, so I decided to let you know.

Ping @Drigax and @bghgary for follow up on this one.

@DeepDeeh Can you share an example where this occurs?


Good one. I’ve fixed this in Don't load empty data into attributes for Draco by bghgary · Pull Request #8281 · BabylonJS/Babylon.js · GitHub.

1 Like

I’ve fixed it in the glTF loader, but I should note that the glTF does not seem to be well-formed and maybe a Blender exporter issue. There are UVs on some of the meshes that aren’t used and the Draco version seems to have collapsed the attributes to nothing. The better way to describe this in glTF is to not include the UVs to begin with.

1 Like

Thank you for the quick fix. I don’t really understand the last sentence.

I can delete unused UVs before the export or even uncheck the export UVs with meshes on the export options in blender, if I don’t need UVs at all. But it might be helpfull to keep the UVs in the model, for later (re)work on the model, even if they are not used right now. So maybe the problem is the way the draco compression changes the model? So draco might only be used when the model is finally exported for viewing and not for sharing models.

1 Like

glTF is intended for runtime. Ideally, the asset should not have things that are not used.

But regardless, some Draco UV data after decoding claims there are zero components. The unused UV data is gone as far as I can tell. Maybe you can ask the glTF Blender folks what is happening?

Ok. I think it has been reported here already:

1 Like