GLTF2Export Error

Hi! I’m currently trying to use the GLTF2 exporter to export my models.
Using GLBAsync/ GLTFAsync on the Playground seems to be working just fine, but when I’m using it on a current project, the .bin file is empty / the .glb file downloaded is pretty much empty.

Here’s the code snippet I’m using to download the model (basic usage, without options):

GLTF2Export.GLTFAsync(scene, "fileName").then(gltf => {

I checked for similar issues with an empty .bin/glb, and the only one I found was fixed by updating the dependencies, which I tried (everything is on the 4.2), but that unfortunately didn’t fix the problem.

One of the possible cause of the issue is that I’m using a lot of different materials, and some maybe unsupported. I removed every unsupported materials from the scene, but it didn’t fix it either.

Any ideas where I should be looking ?
Thanks a lot!

Pinging @Drigax

1 Like

Hi, @PhilippeDeSousa, I’m not sure what issues you’re running into. I created a simple test page that loads our 4.2 engine and serializer, but it seems to work without issue:

Are you getting any console errors when exporting, or using a callback to select the meshes to be exported?


Thanks for your answer.
I’m currently trying to create a playground to show more precisely what my issue is.
I exported my scene as a .babylon file and uploaded it on github.
I created this playground:, but I have an issue loading the environment texture. The URL it’s trying to load it from includes the URL i’m getting my .babylon file from (, any idea how to fix it ? (it’s not a problem when I’m loading it in the sandbox, so I’m thinking it’s not coming from the file itself).

Thanks a lot


I managed to fix the playground, and exporting the GLB seems to be working just fine (
However, as I mentionned in my original post, whenever I try to do it on my project, I run into the empty .bin file.

My issue is very similar to this one:

In his post, he mentions that he ran into a dependencie issues, but he actually had an error that showed him some information, but I have none.

Any idea how that issue could be fixed / find if it’s a dependencie issue ?


Finally managed to find the issue.
I was using babylon-serializers instead of using the ES6 module (@babylonjs/serializers)