GLTF2Exporter seem like having some bug

Hi, Everyone, seem like I encountering some bug, can I know why if I exported the scene with babylon inspector, no issue.
url: BabylonInspector Export Model.glb - Google Drive
but when I export with GLTF2Export, then the whole glb file auto change the mesh to transform node, idk why, U can check the glb file on sandbox babylon
url: GLTF2Export Model.glb - Google Drive

GLTF2Export.GLBAsync(scene, “model”).then((glb) => {

@babylonjs/core”: “5.45.0”,
@babylonjs/gui”: “5.45.0”,
@babylonjs/gui-editor”: “5.45.0”,
@babylonjs/inspector”: “5.45.0”,
@babylonjs/loaders”: “5.45.0”,
@babylonjs/materials”: “5.45.0”,
@babylonjs/serializers”: “5.45.0”,
“babylonjs”: “5.45.0”,
“babylonjs-hook”: “^0.1.1”,
“babylonjs-loaders”: “5.45.0”,
“react-babylonjs”: “^3.1.15”,

Do you mind reproducing the issue in the playground?

Here is the code used in the inspector: Babylon.js/toolsTabComponent.tsx at master · BabylonJS/Babylon.js (

u can try to download this, seem like also same issue

I’m not seeing anything amiss on the downloaded file of this playground?

Same I tried both from the inspector and within the code with the same exact outcome and expected model.

Could you try cleaning you node modules before retrying ???

I am suspecting a version issue of some sort.

I tried before, I also suspecting a version issue, so I updated all my babylon package into new version, and I clear my node modules too many time, maybe I check again see how

Issue Solved :face_exhaling:

because I import { GLTF2Export } from ‘babylonjs-serializers’…
I no yarn add babylonjs-serialize before, dk why it works…even I clicked GLTF2Export, IDE also redirected me to the node_modules/@babylonjsxx/serializers

but after I import { GLTF2Export } from ‘@babylonjs/serializers/glTF’; no more issue

1 Like